Sábado, 03.01.09

Um dia triste para o Debian

Apesar de um ou outro problemas normais com versões não-estáveis de qualquer aplicação ou sistema, eu estava satisfeito com o Debian Lenny. Tenho um desktop todo janota, tenho as coisas que me interessam e como as quero, faço as minhas cenas sem problemas. Resumindo: a vida era boa com o Debian.

Era, mas já não é, porque o Debian Lenny vai incluir blobs no kernel, na versão final. Agora, estou a pensar em voltar a instalar o gNewSense ou então compilar o Linux-Libre, um projecto que limpa o Linux de blobs. Ainda não decidi o que fazer, mas devo fazê-lo até ao lançamento do Lenny.

Estou um pouco triste com o Debian. Sempre vi este projecto como um exemplo na comunidade livre, por isso fico desagradado com esta decisão. Barafustaram tanto - e com razão - por causa das questões da trademark do Firefox, acabando por fazerem um fork deste browser para resolver a questão, e agora tomam uma decisão destas.

publicado por brunomiguel às 16:43 | link do post | comentar | ver comentários (8)
Quarta-feira, 25.06.08

Restituir o som no gNewSense 2.0

som gnewsense ubuntu módulos driversComo o Ubuntu tem vários módulos livres e não-livres no pacote linux-ubuntu-modules, o gNewSense removeu-o dos repositórios até conseguirem remover todos os blobs. Isto faz com que, de momento, algum hardware com drivers livres não funcione.

Algum desse hardware que deixa de funcionar é as placas de som, como a minha SoundBlaster Live, que até tem drivers livres para ela.

Felizmente, voltar a ter som é bastante simples. Para futura referência, deixo os passos necessários para restituir o som, retirados da página da Wiki do Ubuntu sobre a configuração da SoundBlaster Audigy SE no Ubuntu Edgy.


COMO RESTITUIR O SOM NO GNEWSENSE 2.0:

Primeiro, é necessário instalar o pacote alsa-source, onde estão os módulos necessários:
sudo apt-get install alsa-source

De seguida, são necessários mais alguns pacotes:
sudo apt-get install linux-headers-$(uname -r) build-essential module-assistant

Para o caso de faltar alguma dependência:
sudo apt-get -f install

Agora, à que escolher o driver correcto, que será posteriormente compilado. No meu caso, é o EMU10k1:
sudo dpkg-reconfigure alsa-source

Depois do driver escolhido, falta a compilação e instalação:
sudo module-assistant auto-install alsa-source

Por último, reiniciar.

publicado por brunomiguel às 08:58 | link do post | comentar
Segunda-feira, 23.06.08

Colaboradores do Linux exigem fim de software fechado no kernel

Finalmente, alguns colaboradores do desenvolvimento do Linux - 141 colaboradores, para ser preciso - bateram o pé e publicaram uma petição onde exigem o fim dos blobs neste kernel.

Os blobs são software fechado, como o Windows ou os drivers oficiais da nVidia, por exemplo. Para além de fazerem com que o kernel Linux viole a GPL, são uma possível fonte de problemas de segurança, pois não é possível aos colaboradores do Linux ver se eles são seguros e corrigir eventuais falhas de segurança.

Pessoalmente, e digo isto com muita pena, não me parece que vá ter um efeito imediato, apesar de nomes como Theodore Tso assinarem a petição.

Se querem usar um sistema livre de blobs, quer por questões de segurança, quer por defesa da vossa liberdade digital, optem por sistemas operativos que utilizam apenas software livre. No GNU.org está uma lista que poderá servir-vos de guia na escolha de um sistema livre.

via Programas Livres

publicado por brunomiguel às 14:29 | link do post | comentar

do not feed the trolls

Outros blogs meus

pesquisar neste blog

 

posts recentes

arquivos

links